Monthly Archives: September 2009

–no-ri –no-rdoc for ruby gem installation

One can install gem without rdoc using gem install GEM_NAME –no-ri –no-rdoc Skip ri rdoc for all gem installation as i haven’t seen anyone using it. Edit gemrc fileAdd following line to itvi ~/.gemrc:gem: –no-ri –no-rdoc Here is my ~/.gemrc … Continue reading

Posted in Ruby | Tagged , | 1 Comment

Managing multiple ruby versions and rails versions with rvm

While working with many projects that uses different ruby versions and rails versions, one big problem arises that how do we manage all this ? We know that managing multiple rails versions wont be problem at all.but what about ruby … Continue reading

Posted in Ruby, Ruby on Rails | Tagged , | 2 Comments

jruby rails installation on ubuntu interpid

# install mysql if you dont have already installedsudo apt-get install mysql-server mysql-client libhtml-template-perl mailx dbishell libcompress-zlib-perl mysql-doc-5.0 tinyca # install ant and jdksudo apt-get install ant sun-java6-jdk # install jrubymkdir softwarecd softwarewget http://dist.codehaus.org/jruby/jruby-bin-1.1.5.tar.gztar xvfz jruby-bin-1.1.5.tar.gzln -s jruby-1.1.5 jrubyexport PATH=$PATH:$HOME/software/jruby/bin … Continue reading

Posted in Ruby on Rails | Tagged , | 1 Comment

upgrading rails version

Here are the simple steps to be followed while upgrading rails version to use. # Install rails version1. gem install rails -v == gem install rails 2.3.3 # Upgrade environment.rb for new version2. RAILS_GEM_VERSION = ” unless defined? RAILS_GEM_VERSION == … Continue reading

Posted in Ruby, Ruby on Rails | Tagged | Leave a comment

Installing ruby 1.9.1

installing ruby 1.9.1 is very easy …….follow simple steps wget ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.1-p0.tar.gz tar -xvf ruby-1.9.1-p0.tar.gz cd ruby-1.9.1-p0./configure makemake testsudo make install Thats, it !

Posted in Ruby | Tagged , | Leave a comment

Migrating project from rails 2.1.0 to edge rails 2.3.3

I wanted to migrate my project from rails 2.1.0 to rails 2.3.3so, i performed following steps, but it shows me memcached-client error. vi config/environment.rb # Specifies gem version of Rails to use when vendor/rails is not presentRAILS_GEM_VERSION = ‘2.3.3’ unless … Continue reading

Posted in Ruby on Rails | Tagged | 1 Comment

Thank You

Thanks for your valuable feedback!

| Leave a comment